Open source changelog

Follow the evolution of Gatsby.

Subscribe to updates

Description

Fixes a typo in a log message

Documentation

Related Issues

This updates strip-ansi to version ^6.0.1 to fix this vulnerability issue: https://www.npmjs.com/advisories/1004946.

I don't know how to test this, but would gladly help, if I can get a bit of guidance.

  • According to https://github.com/chalk/strip-ansi/releases/tag/v6.0.0, upgrading to version 6 requires changing import stripAnsi from 'strip-ansi'; to import stripAnsi = require('strip-ansi');. I did not make this change because VSCode only accepted the current syntax, and my experience is that VSC…

Description

The URL for the gatsby-plugin-segment-js docs was wrong - it was missing the leading /, so it was taking people to a 404. Current: https://www.gatsbyjs.com/docs/plugins/gatsby-plugin-segment-js This PR updates to:

Documentation

Minor updates